Excel – kopírujte vzorce, aniž by se měnily odkazy na buňky

Jedna ze základních vlastností Excelu je, že se při kopírování snaží vždy převést kopírované vzorce v tom tvaru, aby fungovaly i v novém umístění (mění tedy sám odkazy v buňkách). Tj. když budu mít např. v buňce C1 vzorec =SUMA(A1:A2), po zkopírování se v buňce C2 objeví jako =SUMA(C1:C2). To je ve většině případů výhodné, protože ušetříme čas s editací vzorců.

V některých případech se nám to ale nehodí. Potom využijeme možnosti „zafixovat“ odkazy ve vzorci pomocí klávesy F4(nebo vložením znaku $). Zafixovat jde buď adresu celé buňky (např. $B$4), nebo jen sloupce ($B4), nebo jen řádku (B$4). Obvykle se tomu říká „absolutní adresa“.

Praktický postup

Typický příklad je, že budeme chtít násobit jednotlivé buňky vždy stejnou hodnotou, obvykle nějakým koeficientem, který zůstává pro řadu buněk stejný. V našem případu je koeficient v buňce B1. V buňce C5 bychom ještě vystačili s jednoduchým vzorcem =C5*B1:

snímek obrazovky

Když ale tento vzorec nakopírujeme do buněk C6 a C7, je evidentní, že něco není v pořádku. V řádku 7 přece nemůže vyjít nula! Z pohledu Excelu je ale vše logické: =B7*B3 je přece 28500000 x 0 = 0:

snímek obrazovky

Proto nyní nezbyde, než „neposlušný“ výchozí vzorec upravit ručně. Klikneme do C5, dáme F2, a potom F4. Vzorec se nám přepíše na =B5*$B$1.

snímek obrazovky

Po rozkopírování už bude vše v pořádku, protože ve všech kopírovaných vzorcích bude nyní $B$1:

snímek obrazovky

Poznámka:
Jiná možnost, jak zapsat absolutní adresu, je např. kliknout přímo do vzorce – tj. do místa označeného výše červenou hvězdičkou umístit kurzor a pak opět mačkat F4. Kdo nemá F4 rád, zapíše do správných míst přímo znak pro dolar (tj. pravý ALT + Ů).